Posts by einencool

    Wegen der Position Abweichung bei den ihss Steppern kann ich nur beitragen, dass die originalen Werte viel zu hoch eingestellt sind, und erst ab mehreren mm auf Störung gegangen wird.

    Die standen von Haus aus auf 400 (was auch immer? Steps??) und habe diese nun seit fast nem Jahr auf 40 stehen ohne Probleme.

    Bin damals mit fast G0 in nen Schraubstock mit 13er Wsp Fräser gedonnert und er ging noch nicht auf Störung...

    Daher kann ich das mit Sicherheit berichten ;-)


    Allerdings regeln sie trotzdem sauber nach, also der Wert hatte keinen Einfluss darauf.

    Wenn du nur ein Werkzeug benutzt, und direkt auf dem Werkstück abnullst, benötigst du ja auch keine weitere Verrechnung.

    Diese Verrechnung erfolgt auch eigentlich immer von einer Referenz aus.

    Bei mir ist es so, dass ich erst die Höhe des Werkstücks abnulle, und dann noch eine Referenzmessung zu meiner Basisplatte mache. Zumindest, wenn ich Werkzeugwechsel habe. Wenn nicht, wird einfach nur auf dem Werkstück abgenullt und los gehts.

    Habe bei mir der Einfachheit einen Schalter / Relais vor das Netzteil der Schrittmotoren gehängt, damit hat sich das dann eh erledigt, Das Netzwerkkabel zur Signalübertragung war leider schon kpl. belegt :-)


    Mache das allerdings meistens nur selten, weil ich danach immer noch mal die Maschine Home, damit vorallem das Portal auch wieder wirklich gerade steht. Das ist unabhängig mit 2 Motoren angesteuert, und es kam sonst in der Vergangenheit vor, dass beide Motoren jeweils den „Vollschritt“ gegeneinander getroffen haben. Dadurch hatte ich dann öfters 0,05-0,08mm Schiefstellung nur durch das Anschalten der Motoren.

    Möchte auch eine kurze Einschätzung geben.
    Habe meine Fräse auch vorher mit einem Closed Loop System von ACT-Motors (Ebay usw.) genutzt.
    Die Motoren waren absolut in Ordnung, und für meine Verhältnisse hätten diese auch definitiv weiterhin ausgereicht.


    Allerdings war die Neugier groß und weil alle davon schwärmen, habe ich mir auch die JMC IHSS mit 3Nm gekauft.
    Alle 4 einzeln über Ali direkt bei JMC bestellt.
    Heißt also Stückpreis um die 80€ Zzgl „evtl. Anfallender Kosten“


    Was mich im Stillstand der Motoren doch wirklich extremst nervt, ist ein sehr hochfrequentes fiepen, was andere hier wohl auch berichten. Beim Fräsen stört es nicht, das ist klar, aber wenn ich neben der Fräse bin, und da Vor und Nachbereitungen mache, nervt mich das Geräusch doch schon ordentlich


    Was mir allerdings sehr gefällt, dass man die Parameter schön sauber einstellen kann.
    Habe dementsprechend auch die Positionstoleranz deutlich niedriger eingestellt, als dies von Werk aus war.
    Das konnte ich bei den „günstigen“ ACT-Motoren nicht machen.


    Alles in allem bin ich glücklich damit, wenn sie laufen. Wenn die Maschine im Leerlauf steht, gehen sie mir immernoch tierisch auf den Keks...
    Aber das ist nur meine Meinung und ich reagiere leider häufig genervt auf so Spulen und Netzteilfiepen...

    Zusätzlich sollte man darauf achten, dass die Feder gerade für ganz feine Gravierfräser nicht zu stark ist.
    Habe bei meiner gekauften Variante die innere Feder noch um ein paar mm gekürzt.
    Die Tastfläche ist bei meiner Variante gehärtet und daher für die 10 grad Stichel am Anfang tödlich gewesen.
    Jetzt reagiert der Taster sehr sensibel aber trotzdem präzise.

    Servus,


    coole Idee.


    Schau dir im Forum auch mal die Querfräse an.
    Fadi hat sich da auch noch etwas gebaut für die Abweichung während dem fräsen. Falls diese zu groß werden sollten stopt die Maschine.
    Weil es kann ja ein Verzug vor allem während dem fräsen zustande kommen.

    Danke dir Alex,
    Die Stepper sind Closed Loop, und sollten bei Abweichungen vom Soll relativ schnell in den Alarm Modus gehen.
    Hatte diese Werte damals von Serieneinstellungen mittels „HISU“ von 400 (was auch immer das heißt, aber es waren ca. 3-4mm bis der Alarm angegangen ist) dann auf 50 und jetzt auf 25 gestellt.
    Momentan sieht es noch gut aus.



    Wie dem auch sei. Es bleibt ein interessantes Experiment dem ich aus Neugier weiter folgen werde. Ich persönlich bevorzuge aber definitiv die "nur Software-Variante" (sauber eingestellte Mechanik ist immer Grundvoraussetzung).


    Ich frage mich nur auch gerade, ob Die 3D-Taster auf Dauer vibrations und schmutzresistent sind.

    Obwohl die Maschine bedeutend mehr könnte, bin ich eigentlich immer eher deutlich zu vorsichtig unterwegs, daher halten sie die Vibrationen doch recht in Grenzen.
    Ich habe Lukas schon angeschrieben, ob man eine etwas stärkere Feder einbauen kann, und welche er mir empfehlen kann.
    Wegen dem Schmutz mach ich mir bei der Maschine recht wenige Sorgen, da ich zu 95% immer mit Absaugung arbeite.
    Zusätzlich habe ich um die Spindel einen kleinen Fahrbahren Vorhang und hinten am Portal ist ebenfalls ein Vorhang verbaut. Es kommt eigentlich nur ganz selten mal vor, dass ich Späne vom Boden sammeln muss, und die Entschalter sitzen ja auch etwas erhöht.
    Selbst beim Abplanen der Alufläche ist in den hinteren Bereich nichts hingekommen, und das habe ich mit dem 35mm Fräser gemacht, um die Alubahnen in eins abzuziehen (32mm Breite).
    Und leider musste ich meine Absaugung vor ein paar Wochen provisorisch erneuern, und die setzt sich bei etwas längeren Spänen sehr schnell zu (hat jeweils ca. 3 Bahnen gedauert, dann kullerten die Späne unter dem Bürstenschuh immer hervor...)



    Du hast mich falsch verstanden. Natürlich ist es sinn besser als 3/10 Abweichung nach dem Squaring zu haben. Da wäre mir 3/100 schon zu viel.
    Aber wenn beim Squaring das Portal auf einer Seite 3/10 bewegt wird, weil die Endschalter eben nicht gebau auf den Nulllagen liegen, um es auszurichten, wird da noch nix krumm gezogen, das meinte ich.

    Da wirst du wohl recht haben, aber wo ich nur die eine Seite an die KUS montiert hatte, habe ich es von Hand nicht geschafft, das Portal so weit zu drücken, daher möchte ich das Problem einfach so umgehen.



    Aber das ist ja das Schöne, dass niemandem vorgeschrieben wird, wie was zu machen ist.
    Ich wollte es einfach mal so ausprobieren, weil ich diese Art der Schalter genial finde, sie sehr wiederholgenau und einfach einzustellen sind..

    Hi Andreas,


    die Achse wird per Software natürlich nur noch als Y-Achse behandelt, das wird in der Config so eingegeben und Hardwaremäßig erfolgt die Verdrahtung dann über die Y- und B-Achse




    Warum sollte es das Portal "verziehen" wenn man das in Software macht anstatt über eine annähernd gleiche mechanische Position? Das Ergebnis ist doch in beiden Fällen gleich: Das Portal befindet sich nach dem Homing doch in derselben Position, egal ob das in Software oder mechanisch via Taster erfolgt. Oder verstehe ich hier den Unterschied noch nicht?
    Das Einstellen per Software ist eigentlich die einfachste Variante meiner Meinung nach: Die Abweichung von der Winkligkeit messen und den Wert (umgerechnet auf den Abstand der Sensoren zueinander) in der Software als Offset eintragen - fertig :). Mit 3€-Inis bekommt man auch eine Genauigkeit von deutlich <0,05mm hin - oft auch 0,01-0,02mm, je nach Mechanik.


    Ich finde den Ansatz interessant, aber irgendwie nicht vorteilhafter gegenüber einer "richtigen Tandemachse" + Inis...Trotzdem bedanke ich mich für die Vorstellung den interessanten Austausch hierzu :00009320: .

    Naja, nach dem Homing steht die Achse gerade, das ist klar, dass das auch Softwaremäßig so ist, und auch einfacher umzusetzen, versteht sich auch, wenn ich aber jetzt den einen Ini auf 0 habe und den anderen z.B. 0,3mm dahinter, dann fährt mir die Maschine beim Homen das Portal erstmal die 0,3mm krumm, um es dann hinterher wieder auszugleichen. Deswegen bin ich kein Freund der Software mäßigen Kompensation bei einer aus meiner Sicht schon recht steifen Maschine. Wenn ich hier ne MPCNC oder eine Holzfräse stehen hätte, würden wir uns definitiv nicht darüber unterhalten. :-)


    Aber das ist ja das Gute, dass es immer verschiedene Ansichten für die Dinge gibt, und für mich ist das so schon eine sehr elegante Lösung, die allerdings auch entsprechend Kostenintensiv und auch recht sensibel ist.

    In Anlehnung an den Beitrag 3D-Kantentaster auch als Z-Finder nutzen von Bambusbjörn habe ich vorher schon mit dem Gedanken gespielt, mein Portal der Fräse entsprechend ausrichten zu lassen.
    Dies wurde schon von Anfang an mit 2 JMC IHSS36-60-30 betrieben, allerdings direkt an einen Anschluss angeschlossen, mit auch nur einem Endschalter.
    Hier konnte beim Anschalten der Maschine des Öfteren festgestellt werden, dass die Motoren jeweils in den vollen Schritt allerdings entgegengesetzt eingesprungen sind (auch nach mehrmaligem Stromlosen Ausrichten und lösen der Riemen).
    Dadurch hatte ich immer wieder Ungenauigkeiten bis zu 0,07mm nur durch das Anschalten der Maschine..


    Da die von Daniel vorgestellten Taster Preislich recht interessant sind, und für mich als Elektroniklaien einfacher zu verarbeiten sind, als diese direkt selbst herzustellen, habe ich mit Lukas (dem Hersteller) Kontakt aufgenommen, und so ist das ganze ins Rollen gekommen.


    Da meine Steuerung eine Abwandlung von GRBL ist, die aber noch recht frisch und in der Weiterentwicklung ist, war das Squaring des Portals auch schnell implementiert.
    Meine Platine ist ebenfalls eine Open-Source Variante, die auf einer "Teensy 4.1" Platine aufbaut.


    Jetzt konnten die beiden Motoren als Y- und B-Achse angeklemmt und konfiguriert werden.
    Dementsprechend auch an die beiden Motoren eigene Endschalter zum Homen an der Y-Achse.


    Natürlich hätte dies auch günstiger mittels Inis realisiert werden können, wer allerdings wie ich, vorgeschädigt durch die die Arbeit, täglich mit Messtechnik zu tun hat, möchte dies natürlich auch Stückweit in der eigenen Werkstatt einsetzen.
    Besonders, wenn man sieht, wie wiederholgenau und einfach diese Taster einzustellen sind.


    Also wurde das Portal gerade ausgerichtet und daran dann die beiden Endschalter so eingestellt, dass beide gleichzeitig auslösen.


    Man hätte natürlich auch die Ausrichtung über die Software machen lassen können, allerdings möchte ich mir mein Portal nicht unnötig durch die Maschine verziehen lassen.
    Die Portalwangen bestehen aus 25mm Aluplatten und das Portal selbst aus einem 80x160er Aluprofil. Die Liniearwagen wurden jetzt im Zuge noch auf mittlere Vorspannung eingestellt, weil diese von den Chinesen etwas zu locker auf der Schiene liefen...


    Beim Ausrichten des Portals fiel es mir schon schwer genug, zum testen mal ein 0,05mm Blech diagonal hinter das Portal zu legen, selbst mit komplett gelockerten Schrauben ging dies nicht so einfach und daher musste hier schon mit Hilfe der KUS nachgeolfen werden (diese war vorher zum Einstellen nicht montiert bzw. im Eingriff...) Hinterher waren es dann 2 Lagen Aluflolie diagonal dahinter, und das Ausrichten klappt jetzt beim Homen absolut zuverlässig.


    Damit es in einem Fehlerfall nicht zum kompletten Verdrehen des Portals führt, wurde noch eine "Softwareseitige Sicherung" eingebaut, dass nach max. 0,1mm der Homingvorgang abbricht, wenn nicht beide Schalter auslösen.


    Einen Nachteil habe ich allerdings dann doch bemerken müssen.
    Dadurch dass die Sensoren so sensibel sind, habe ich beim Werkstück aufspannen doch schon ein paar mal den Sensor ausgelöst.
    Aber nur, wenn ich mit Schraubstock, Parallelleisten und "Hammer" arbeite.
    Der Hammerschlag reicht aus, dass einer der beiden Schalter auslöst.


    Aber auch da ist jetzt schon eine Softwareänderung in der Mache, sodass bei Stillstehender Fräse ein kurzzeitig auslösender Endschalter keinen bleibenden Alarm auslöst, sondern nur angezeigt wird...
    Das werde ich hoffentlich in der nächsten Woche mal testen können.


    Falls Fragen sind, immer her damit :-)

    Auch da hast du recht, bin allerdings nicht der Freund davon erst etwas unnötig krumm zu ziehen, weil die Endschalter nicht gleichmäßig sind, um es dann wieder gerade zu richten.


    Hätte ehrlicherweise aber nicht damit gerechnet, dass das jetzt so ein Problem hier verursacht.
    Die meisten machen hier Sachen zum Hobby, und das bedeutet ja oft genug, mit größtmöglichem Aufwand, den geringsten Nutzen daraus zu ziehen. Aber da hab ich mich hier wohl verirrt :D

    Es geht darum, dass das Portal auf beiden Seiten von den beiden unabhängig voneinander laufenden Motoren gerade ausgerichtet wird.


    dazu wurde das Portal vorher natürlich ausgerichtet und damit beide Endschalter exakt gleich kommen, wird das mit den Madenschrauben eingestellt..
    Ja klar hätte man das auch beim Ini mit den Muttern und ner zusätzlichen Tastschraube einstellen können, das ist mir alles auch bewusst...

    Tastweg liegt bei glaube ich mehreren mm Luft, schätze so knappe 3mm Auslenkung pro Richtung.


    Aber die 500mm/min beim ersten Anfahren, da hält die Maschine innerhalb eines knappen Zehntels an.


    Ich sehe den Mehrwert gegenüber einem nor allen Ini darin, dass sich diese extremst einfach einstellen lassen mittels der kleinen Madenschrauben.


    Gerade diese Schalter würde ich nie Frontal anfahren lassen, gerade dann drückts direkt in die Elektronik.
    Falls so mal was schief laufen sollte, verdrückt es eigentlich nur die auswechselbare Spitze.

    Beim gravieren werden ja meist mehrere achsen synchron Verfahren, da könnte ich mir vorstellen, dass es mit den kurzen Signalen oder Störungen auf den Leitungen zu tun hat oder eben Stromversorgung bricht kurz ein.
    Oder eben immer noch, dass die bewegte Masse nicht hinterher kommt.


    Da kommt man sich mit den kleinen 3Nm JMCs ja richtig klein vor *g*

    Auch wenn ich dir nicht direkt helfen kann.
    Positionsfehler könnten für mich 2 haupt-Ursachen (neben zu geringer Stromversorgung) haben.


    Entweder Beschleunigungswerte zu hoch, dass er die bewegte Masse nicht schnell genug bewegt bekommt und dann der Motor in Störung geht,


    Oder die pulse sind von der Zeit recht kurz. Kenne deine Steuerung nicht, aber 4-5 us ist finde ich sehr knapp, glaube ich.

    Wollte noch mal ein kurzes Feedback geben, was die Durchmesser und Vorspannung angeht.


    Habe gestern die P3 Kugeln erhalten und direkt in einen Wagen eingebaut. Naja, was soll ich ich sagen, das war dann nix, denn der Wagen war so leicht auf der Schiene, dass er schön weiterrollte, wenn man ihn schnell geschubst hat.


    Lange Rede, gar kein Sinn..
    Jetzt weiß ich endlich, was die gekritzelten Zahlen auf der Rückseite zu bedeuten haben.
    Bei meinen Stand z.B.
    33 -7
    33 -6
    33 -3 und
    33 +3
    Drin.
    Heißt, 33 Kugeln pro Reihe (132 Kugeln/Wagen) und dann ob die Wagen kleiner (z.B. -7um) oder größer (+3um) sind.


    Habe natürlich genau richtig getroffen, den kleinsten mit -7um hatte ich mit den P10 Kugeln ausgerüstet und den +3um mit den P3 Kugeln, also war demnach der eine Wagen mit 17um vorgespannt, und der andere genau auf 0um
    Habe jetzt mit den P3 und P10 Kugeln die Wagen soweit recht gleichmäßig bekommen.


    Aber den -3um Wagen, wollte ich gerne bei 2 Umläufen mit P3 und 2x mit P10 ausrüsten.
    Seht ihr da Probleme bei? Falls nein, welche Umläufe sollten den gleichen DRM haben? Jeweils unten / oben getrennt, oder eine Seite P3 und die andere P10?


    Oder soll ich den -3um Wagen nur mit P3 Kugeln ausstatten, dann hätte er die selbe Vorspannung wie der +3um Wagen mit P10 Kugeln


    Dann wäre ich mit allen Wagen bei ca.10 bzw. 6um Vorspannung.

    Nutze öfters ne Ethanol Wasser Mischung.
    Meist so 30/70 oder 50/50.
    Je nachdem was gerade zusammenkommt. Nehme es da nicht so genau.
    Die 30% reichen aber aus meiner Sicht für meine Belange aus.
    Meist Fräse ich allerdings trocken, nur bei Bohrungen oder vielen Nuten wird geschmiert.
    Bei den Billig Fräsern kann ich trotzdem keinen erhöhten Verschleiß feststellen und die Oberfläche ist für mich ausreichend.

    Mit dem NC Anschluss hat man zudem aus meiner Sicht den Vorteil, wenn man den Taster im nicht benötigten Fall zur Seite packt, man nicht vergessen kann, das Kabel wieder anzuschließen.
    Oder wenn beim Antasten unbemerkt das Kabel sich löst und er dann nicht mehr schalten kann...

    Das stimmt, bei mir war es eher, dass genau an der untersten Ecke der Schneide dann mal ein Reststück Holz hing, und es dadurch dann mal nicht sauber ausgelöst hat. Daher hatte ich den damaligen Selbstbau Tastblock auch gefedert ausgeführt.


    Bei der neuen Maschine bin ich dann allerdings auf einen schaltenden Taster gewechselt, weil ich diesen Eingang auch gleichzeitig für den 3D-Taster nutze. Da ging es dann nach dem „Kurzschluss-Prinzip“ nicht mehr.


    Aber da der Tastkreis immer geschlossen ist, und beim Berühren öffnet, ist es auch egal, ob da ein Hauch verbranntes irgendwas die Leitfähigkeit herabsetzt. Das war es mir dann doch Wert und habe es zum Glück nicht bereut, obwohl ich meinen selbstgebauten Taster schon echt gern benutzt habe, weil es die erste Erweiterung meiner damaligen Fräse war.

    Danke dir Michael,


    Hab mir heute mal lieber noch die 3,969 P3 Kugeln bestellt, weil mir die P10er dann doch deutlich zu stramm gesessen haben. Ich glaube für ne Zeit wäre das ganz OK gewesen, aber mit der starken Vorspannung habe ich dann doch irgendwie meine Bedenken bei den „günstigen“ Schienen, dass diese dann irgendwann mal blockieren und mir dadurch alles verzogen wird...