Pinned iHSV57-Servos parametrieren

    This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

    • So, wieder gebastelt. Habe jetzt überall Pf 1350 eingestellt, die POS Error line Eiert beim hin und her fahren etwas hin und her. PP habe ich auf 2 Achsen ah 32767 stehen, auf der einen auf 25000, das ist die Achse die etwas brummte.PD auf null. Der Torque Current hat ziemlich große ausschläge.
      Gruß
      Willi
    • Hallo Willi.

      Also wenn Dein Position Error zwischen -1 und +1 schwankt, dann ist das das Optimum, vermute ich zumindest. Der Regler im Servo passt sich ja den Gegebenheiten an und versucht den Fehler zu minimieren. Damit er was korrigieren kann, muss er aber natürlich erst mal wissen, dass etwas daneben ist. Und +-1 ist halt irgendwie der minimal mögliche Fehler, den er dann sofort korrigiert.

      Etwas größere Fehler bei starken Beschleunigungen sind auch einfach der Physik geschuldet. Und wenn das nicht Überhand nimmt, dann kann man die wahrscheinlich auch vernachlässigen, da die ganze Fräse sich etwas "biegt" bei starken Beschleunigungen. Wahrscheinlich mehr als der Postionsfehler vom Servo. Wobei letzters eine reine Vermutung von mir ist.

      Die letzte Achse, wo Du Pp auf 25000 gesenkt hast, konntest Du nicht mit einem niedrigeren Pf-Wert "beruhigen"? Das verwundert mich etwas, da bei meinen Test auch ein ausgebauter Motor mit maximalem Pp und niedrigem Pf-Wert nicht geschwungen hat.

      Torque Current schwankt bei mir auch recht stark (so +- 100mA), da mache ich mir aber keine Gedanken. Erstmal sind 100mA jetzt nicht ein so riesiger Ausschlag absolut betrachtet und solange der Positionsfehler gering ist, bin ich zufrieden. :)

      Haben sich Deine Fräsergebnisse denn verbessert?

      Tschüss,
      Lars
    • Ich habe das jetzt noch einmal ausprobiert. Ein höher Pd Wert verschlimmert das ganze, Pf ändert sich nicht viel. Ich habe immer noch dieses schwingen aber nicht mehr so doll, kann ich auch an der Kurve sehe. Das ganze dauert ein paar Sek. und hört dann von alleine auf. Das schwingen ist immer um die +- 1.
      Gruß
      Willi
    • Hallo
      mein name ist Olaf und ich bin schon längere Zeit hier im Forum als passives Mitglied lesend unterwegs
      habe nun meine Fräse mit Servos ausgerüstet

      und da ist noch die ein oder andere Frage offen ?(

      z.B.
      beim monitoring der JMC Servos iHSV57-30-18-36
      welches fenster ist den für die schrittverluste verantwortlich [Blocked Image: https://cncwerk.de/forum/images/smilies/icon_rolleyes.gif]
      Pos Error oder Vel Error und was sagen mir die anderen fenster ?
      wie hat so eine Kurve im Idealfall auszusehen ?

      und hir meine Fräse youtube.com/watch?v=VZLCuhc9RlM

      Gruß olaf
    • Schrittverluste (im klassischen Sinn) gibt es bei Servos nicht, da sich der Servomotor kontinuierlich bewegt. Man gibt dem Servo lediglich vor, bitteschön soundsoviele Encoder-Striche weiterzudrehen, und dieser Vorgabe folgt der Servomotor dann entweder zu langsam (das wäre ein Schleppfehler), oder er schießt übers Ziel hinaus und fängt an zu schwingen, oder oder... Dazu dann die Abstimmung der Regelparameter. Ziel ist, das der Positionsfehler zu jeder Zeit möglichst klein ist. Nicht nur am Ende der Bewegung, sondern auch während der Bewegung. D.h. du sagst über deine Steuerung "fahre 100mm". Es reicht nicht, wenn das Servo dann auch tatsächlich die 100mm fährt, es muß auch zur richtigen Zeit an den 50mm vorbeikommen, sonst werden Kreise nicht rund.

      In den Fenstern der Software siehst du daher immer eine Sollkurve (was die Steuerung vorgibt), und eine Istkurve (wo sich das Servo tatsächlich gerade befindet). Die Differenz ist der Pos-error, der soll klein sein.
    • Hey Olaf, ich habe eigentlich nur an Pp, Pf und Pd etwas eingestellt. Wenn du dir mal die Original Anleitung zu den Servos durchliest, wirst du sehen, das einige Parameter gar keine Funktion haben. Da kann man zwar etwas einstellen aber die Servos können das nicht, da diese Funktionen nicht vorgesehen sind.
      Gruß
      Willi
    • Bei dem Ihvs Tool, gibt es keine Sollkurve. Lies dir mal hier alles durch, dann hast du die wichtigen Sachen zusammen. Du kannst die Ihsv Servos, nicht mit den großen Industrie Servos vergleichen. Bestimmte Parameter gibt es nicht, stehen zwar drin sind aber eher ein Fake. Einfach sonst Googlen. Kennst du den Beitrag von Sebastian End? Ich hab mich zuerst an seine Werte gehalten, dann ein bisschen Experiment und ich habe laut Mach3 einen Verlust von 0,002mm. Mir würden 100tel schon reichen. Mit der Grundeinstellung, der Servos kann man aber auch schon Arbeiten.
      Gruß
      Willi
    • Hallo olaf008.

      Die Soll-Kurve ist "Pos Cmd". Ist-Kurce ist "Real Pos" und die Differenz "Pos Error". ("Pos Error" ist nicht zwangsläufig immer "Real Pos" - "Pos Cmd", da die Werte sequenziell übertragen werden. D.h. zwischen der Übermittlung von "Pos Error" und "Real Pos" und "Pos Cmd" können sich die Werte schon (minimal) geändert haben. Also nicht wundern, wenn sich "Real Pos" und "Pos Cmd" im Graphen kreuzen und "Pos Error" nicht genau 0 ist.)

      Ich habe mir eigentlich immer nur "Pos Error" (zur Fehlerminimierung) und "Torque Current" (zur Schwingungsminimierung) plotten lassen.

      Tschüss,
      Lars
    • Hallo
      Ich habe gerade gesehen dass Sorotec die Servos ins Programm genommen hat.
      die Anleitungen sind teilweise in Deutsch was vielleicht gut ist für die die nicht so gut Englisch können.

      der Preis ist auch OK finde ich. ca. 15€ gegen über den selbst Import
      lG
      Fadi

      Baubericht der 107XL, Idee und Planung der Querfräse

      The post was edited 1 time, last by fadi: Link auf die 180w Servos gesetzt ().

    • Hallo
      Ich hab den Link jetzt angepasst auf die 180W Servos
      Da die 3 unterschiedlichen iHSV57-Servos Baugleich sind und sich nur in der Leistung unterscheiden werden doch hoffentlich die Beschreibungen dazu auch passen und auch die Software wird die gleiche sein.

      die Werte zu Parametrieren werden unterschiedlich sein, nur die Methoden für das richtige Parametrieren werden auch die selben sein.

      Ich wollte eigentlich nur darauf hinweisen wo man die passenden Beschreibungen auf Deutsch finden kann. Es soll immer noch Leute geben die ein technisches Fachenglisch nicht gut verstehen können.
      Und auch wenn man nicht direkt in China bestellen will ist Sorotec ein guter und sicherer Shop dafür.
      lG
      Fadi

      Baubericht der 107XL, Idee und Planung der Querfräse
    • Hallo in die Runde,

      ich habe ein Problem. Eines meiner Servos funktioniert nicht mehr. Ich habe es heute fröhlich parametriert und auf einmal lief es nicht mehr.

      Kabel, Steuerung etc. kann ich alles ausschließen. Das Servo gibt keine Fehlermeldung raus. Ich kann aber eine Verbindung über zum Servo aufbauen und auch Werte in das Servo schreiben. Das Monitoring funktioniert auch. Wenn ich ganz niedrige Werte ansetze kann ich auch einen Positionsfehler (Rote LED leuchtet 3-mal) provozieren

      Es scheint also so, als wenn das Servo für sich selbst funktioniert, aber nicht mehr auf die externen Signale reagiert. Das Servo ist aber auf "External Control" parametriert.
      Grüße,

      André
    • Bastlerhh wrote:

      Da hast du den Fehler schon, ich bin der Meinung, das muss Intern Control stehen. Ich kann mal nachsehen , bin aber erst Dienstag wieder zu Hause.
      HHhhhm, bin nicht sicher. Gemäß dem Video von "Der Normio" muss es auf "External Control" stehen und ich bin recht sicher, dass es auch auf "External Control" stand und so funktionierte. Aber ich werde es heute Mittag nochmal testen.
      Grüße,

      André