Neue Webseite für die deutschsprachige CamBam Community

  • Hallo

    ich habe gestern die neue deutschsprachige Webseite für die CamBam Community in Betrieb genommen.

    Die Seite ist noch Baustelle, aber das wird mit der Zeit besser. Wer das beschleunigen möchte kann mir gerne eine Woche Urlaub auf der Insel bezahlen. Dann mache ich nur sonnen, baden und CamBam Webseite weiterbauen ;)

    Da die alten Passwörter verschlüsselt sind kann ich die für die neue Webseite micht weiter verwenden.


    Wer auf der alten Webseite registriert war, kann den Benutzernamen aus der alten Registrierung weiter verwenden.

    Die alten Passwörter gehen nicht mehr! Wer 5 Mal ein falsches Passwort eingibt kommt für eine Stunde ins Gefängnis. Wer danach weiter versucht sich mit falschen Daten einzuloggen sitzt dann schnell für eine Woche.

    Also, bitte gebt Euch einfach über Passwort zurücksetzen im Menü ein neues Passwort.

    Nachdem Ihr Euren alten Benutzernamen eingegeben habt bekommt Ihr eine E-Mail auf die hinterlegte Mailadresse. Wenn Ihr dann auf den Button in der Mail klickt könnt Ihr Euch einloggen.


    Wer sich neu registrieren will, da gilt das alte Spiel.
    Jeden neu angemeldeten Besucher muß ich erst händisch freigeben bevor er die Seite besuchen kann.

    Das ist mühselig, hält aber seit Jahren die Seite frei von Spam.


    Ansonsten viel Spaß auf der neuen Seite.


    grüße ralfg

  • Hallo Ralf,

    Ich bin erst gestern/heute Nacht zufällig auf das Forum gestoßen, da konnte ich mich aber noch nicht anmelden.


    Ich habe mir grade jetzt auch eine Lizenz gekauft, nachdem du doch immer wieder alle erdenklich Lösungswege mit Cambam aufgezeigt hast, deswegen ist mir ein deutschsprachiges Forum um so lieber. :)

    Letztendlich benötigte ich eine Methode für das Centerline Tracing, um Gravuren erstellen zu können, primär aus vorhandenen Vektordateien.

  • da konnte ich mich aber noch nicht anmelden.

    Glückwunsch zur Lizenz. Das ist eine gute Wahl.

    Die Anmeldung geht jetzt. Oben gibt es jetzt den Link "Registrieren".

    Wenn Du da irgendwas eingegeben hast bekomme ich eine Mail. Ich muss das dann freigeben, dann bekommst Du eine Mail das der Zugang freigeschaltet ist.

    Ging heute schon mehrfach problemlos.


    Das Handbuch im Download ist noch Version 0.9.8. Das erste Handbuch zur Version 1 ist in wenigen Tagen fertig. Ich muss noch ca. 10 Seiten übersetzen.


    grüße

  • Servus in die Runde,


    jetzt muss ich hier mal nachfragen wie es euch beim Aufruf der neuen deutschsprachigen CamBam-Seite geht.


    Irgendwie mag mich die neue Software oder der Server nicht.


    Sobald ich das Glück habe und mich anmelden konnte, fliege ich auch schon wieder raus.

    Wobei es dabei zu unterschiedlichen Meldungen kommt (Verbindung wurde abgelehnt oder Webseite nicht erreichbar).



    Ralf habe ich schon informiert, er kann aber das Verhalten nicht feststellen.

    Die mobile Darstellung der Webseite ist kaum brauchbar.


    Danke für eure kurze Rückmeldung!

    Gruß
    Klaus


    m^5 PFM 2.5, wassergekühlte 2,2KW China-Spindel, Eding-CNC, CamBam, FreeCad, QCad, Solid Edge

  • Hallo Klaus. Ich bin dran. Auch zwischen der Arbeit immer mal wieder.

    Ich habe unter der IP die Du mir geschrieben hattest und zur angegebenen Uhrzeit 5 Fehler im Apache Log gefunden Hier der letzte:


    [client 80.187.81.12] ModSecurity: [file "/etc/httpd/conf/modsecurity.d/rules/custom/007_i360_4_custom.conf"] [line "264"] [id "77140992"] [msg "IM360 WAF: Suspicious access attempt (WP folders)!||SC:/var/www/vhosts/pixelmaker.eu/cambam.pixelmaker.eu/wp-content/plugins/matomo/app/matomo.php||T:APACHE||REQUEST_URI:/wp-content/plugins/matomo/app/matomo.php?action_name=Forum%20%E2%80%93%20Deutsche%20CamBam%20Community&idsite=1&rec=1&r=097999&h=7&m=13&s=30&url=https%3A%2F%2Fcambam.pixelmaker.eu%2Fforum%2F&urlref=https%3A%2F%2Fcambam.pixelmaker.eu%2F&_id=67451f77c97423f3&_idn=0&_refts=0&send_image=0&cookie=1&res=360x747&pv_id=i0RRxT&pf_net=0&pf_srv=13&pf_tfr=4&pf_dm1=318||"] [severity "NOTICE"] [tag "service_i360custom"] [tag "noshow"] Warning. Match of "pmFromFile path_excludes" against "REQUEST_FILENAME" required. [hostname "cambam.pixelmaker.eu"] [uri "/wp-content/plugins/matomo/app/matomo.php"] [unique_id "YoSAeuCk77P5Aq2@Q5Nw8QAAAJg"], referer: https://cambam.pixelmaker.eu/forum/


    Die Firewall erzeugt den Fehler nach einer Brut Force-Abwehr Regel von i360. Das Modul ist gar nicht mehr installiert. Es hat im Frühjahr Fehler produziert, es lies sich auch nicht mehr deinstallieren. Ich habe damals Geld dafür bezahlt das ein IT-ler vom Hoster des Rechenzentrums das Modul entfernt.Ich habe den IT Spezis jetzt eine Mail geschickt, vielleicht sind da noch Fragmente des i360 Moduls irgendwo in den Tiefen des Servers aktiv.

    Der Zugriff geschieht beim Zugriff des Plugins Matomo. Das Plugin habe ich jetzt erstmal abgeschaltet.


    Seltsam ist das der Fehler eben über den ganzen Tag nur 5 Mal aufgetreten ist, eben zwischen 7:08Uhr und 7:13 Uhr heute morgen, von Deiner IP Nummer.


    Mehr kann ich dazu nicht sagen, wie gesagt, ich kann Deinen Zugang löschen dann kannst Du einen neuen machen und Deinen Useraccount und Dein Passwort weiter benutzen. Vielleicht reicht es auch wenn Du Deinen Router neu startest und dadurch eine neue IP Nummer bekommst. Das i360 Plugin vergleicht IP Nummern mit in Datenbanken gespeicherten IP Nummern um so potenzielle Angreifer zu identifizieren.


    Sollte noch jemand Probleme haben, bitte melden…


    grüße

    ralfg

  • Kennen tut das System mich schon, werde aber andauernd gebannt.


    Ralf soll mal bitte meinen Account löschen. Dann melde ich mich neu an.

    Vielleicht bringt das was...

    Gruß
    Klaus


    m^5 PFM 2.5, wassergekühlte 2,2KW China-Spindel, Eding-CNC, CamBam, FreeCad, QCad, Solid Edge

  • Hallo Klaus,

    Deinen Account habe ich gerade komplett gelöscht. Du kannst Dich jetzt neu anmelden. Wir kriegen das schon hin.


    @ Alex: Unter "Kampfhund" habe ich keinen Nutzer. Der einzige Benutzername der was mit Alex zu tun hat ist ein AlexL.

    Ich kann einen Benutzernamen nicht finden nur über die Auskunft das er nicht da ist. Du musst mir bitte etwas mehr Infos geben oder Dich neu registrieren. Eine Verbindung zwischen den alten Forenbeiträgen und Benutzernamen hat der Import des alten Forums nicht hergegeben.


    Ich kämpfe zur Zeit wirklich jeden Tag Stunden daran das neue System ans laufen zu bekommen.

    Von den ca 1200 ursprünglich registrierten Nutzern hat sich mehr als ein Drittel in den letzten Tagen wieder angemeldet.

    Die Fehlermeldungen, wie sie bei Klaus auftreten, kommen sonst nicht vor. Ich bekomme ansonsten nur PHP Fehlermeldungen aus dem Wiki. Da muss ich noch ein Update machen, aber durch diese Fehler wird niemand gesperrt.

    Ansonsten bin ich dabei die Sicherheitsregeln der Firewall Stück für Stück zu ändern. Man glaubt gar nicht wie viele Angriffe auf so ein WP-System durchgeführt werden. Da erstmal raus zu sortieren was aus "China" kommt und was echte Fehlermeldungen sind ist nicht einfach.


    grüße

    ralfg

  • Ja Ralf,

    es sieht gut aus.

    Hab mich mit PC und Handy angemeldet und beide haben bis jetzt eine stabile Verbindung.

    Tut sich noch was in der mobilen Version?

    Die ist aktuell so nicht zu gebrauchen. Im Desktopmodus sind aber alle Buttons erreichbar.

    Gruß
    Klaus


    m^5 PFM 2.5, wassergekühlte 2,2KW China-Spindel, Eding-CNC, CamBam, FreeCad, QCad, Solid Edge

  • Tut sich noch was in der mobilen Version?

    Es hat sich etwas getan. Man kann wieder navigieren… Auf meinem Eifone zumindest.


    Ich bin zur Zeit aber an zu vielen Ecken gleichzeitig dran. Ich kehre also wieder zum ursprünlichen Plan zurück.

    1.) Zuerst muss das System funktionieren. Dazu muss ich den Plugin-Downloadbereich überarbeiten und das Wiki. Beides ist von der Programmierung her auf das uralte PHP 5.6 ausgelegt und wurde von mir auf PHP 7.4 gezwungen. Unter Zwang funktioniert man nicht sauber, weiß ja jeder.

    2.) Bis dahin sollten sich versteckte Fehler gezeigt haben die ich zwischendurch eliminiere, gnadenlos…

    3.) Zum Schluss die Optik, dann mach ich das noch etwas nett. Die Seite "Menü -> Downloads -> CamBam Programm Download" hat so zielmlich das Layout was sich dann durch die Seite ziehen soll. Das denke ich mir so.


    grüße

  • Hallo Ralf,


    Ja ok schade :(


    Habe mich jetzt neu registriert, komisch ist am Smartphone dass es mir noch immer die Eingegebenen Daten anzeigt.

    Wenn ich Sie aber nochmalig absende steht, User existiert bereits. Also eine Weiterleitung fehlt da irgendwie das man sich jetzt registriert hat.

    Evtl. liegt es aber auch am Smartphone...



    Falls irgendwas brauchst sag Bescheid!

    Das WP Zeug wird wirklich massiv angegriffen, hab es auf einer Homepage, sperre dort die halbe Welt aus damit es besser wird.

  • So, jetzt kannst Du dich anmelden, Alex.


    Es ist so wie ich es immer schreibe. Einen neuen Zugang muß ich erst händisch freischalten. Es gibt kein automatisches Login mehr. Neuanmeldungen werden erst nach Prüfung zugelassen. Deshalb hab ich kein Problem mit Forenspammern. Für die neuen User bedeutet es manchmal etwas Wartezeit.

    Deine Anmelde-Mail kam gestern um 23:50Uhr. Da lag ich noch in einer Siebdruck-Maschine und habe repariert. Die Mail hab ich erst heut morgen nach dem wachwerden, also gegen 11:30 gesehen. UND DANN DIREKT FREI GESCHALTET :thumbup:

    Ich bekomme nach einer Anmeldung eine Mail. Wenn ich das nächste Mal am Rechner bin schalte ich frei. Beim alten Joomla System brauchte ich nur auf einen Link zu klicken um den neuen User frei zu schalten, jetzt muss ich das über ein Plugin in WP machen.

    Das wird sich einspielen.


    Die vielen Angriffe auf PHP Systeme auf meinem Server werden eigentlich gut erledigt. Ich habe seit 20 Jahren drei eigene Root-Server im Regensburger Rechenzentrum, die losgelöst von allen Cloudproblemen ihre Arbeit machen. Alle 5 Jahre werden die Rechner mal getauscht. Die Systeme sind immer aktuell. Ich hab Freunde die haben vor 3 Jahren ihr Geschäft mit Shopsystemen und Warenwirtschaft auf AWS umgebaut. Hätten sie das Geld wären sie morgen dort wieder weg. Da funktioniert so wenig das sie einen festangestellten IT-ler brauchen.


    Die größten Probleme mit dem Wordpress habe ich durch die unüberschaubare Menge an Plugins. Am Registrierungs-, Rollenvergabe- und Freischaltungsprozess sind derzeit 5 Plugins beteiligt, nochmal soviel braucht das bbPress Forum um auf jetzigem Stand zu funktionieren und es kommen noch einige dazu, wie ein Private-Nachrichten System, wenn alles mal läuft. Damit kann ich zwar das zusammenbauen was ich erreichen will, aber auch nach den zwei Wochen ich könnte das jetzt nicht mehr nachbauen. Dabei gibt es dann für jedes Plugin noch 100 Alternativen.

    Mit dem grafischen Aufbau habe ich keine Probleme, aber auch da geschehen manchmal abenteuerliche Dinge, da springen dann irgendwelche Blöcke einfach weg und gehorchen nicht mehr.

    Das war früher mit schlankem HTML und CSS alles einfacher.


    grüße

    ralfg

  • Hallo Ralf,


    Dankeschön :)


    Ja das kenne ich nur zu Gut...

    Cloud, alles super und wenn es mal Probleme gibt hilft dir kein Mensch.

    Bin da auch ein verfechter von.


    Bezüglich WordPress.

    Haben da auch selber was gebastelt und wehe man klickt auf Update verwürfelt es einem Glatt alles. Vor allem bei so vielen Plugins ist das echt schwierig...

    Habe da jetzt den Weg eines standard Templates gewählt damit man einfach sorgloser updaten kann.


    Letztens habe ich mit einem Freund seinen Server angeschaut, er setzt komplett auf Docker.

    Das hat auch was.

    Backup vom Container, fertig

    Etwas kaputt, Docker löschen Backup Docker starten.

    Das erspart halt mega viel Zeit.

    Vor allem kommt man vom einen Docker zum anderen nur wenn es freigegeben wird.

    Somit kann das Hauptsystem besonders gesichert werden.


    Mich hat die Einfachheit und Schnelligkeit echt beeindruckt.


    Müsste man hier fürs Forum bei einem Crash oder Umzug auch mal andenken.