Planet-CNC Problem beim Import der Tooltable

  • Hi Leute,

    manchmal ist der Umstieg auf eine andere Software nicht einfach,da ich nicht weiß liegt das Problem am Programm

    oder bin ich es. Habe gestern daheim eine Tooltable erstellt und exportiert die ich heute an der Maschine importieren wollte.

    Ich kann die gespeicherte Tooltable im *.csv Format auch auswählen und laden aber die Daten werden nicht übernommen.


    Da es ein csv Format ist kann man ja überprüfen welche Fräser drinstehen. Beim Export werden neu angelegte Fräser

    aber reingeschrieben.

    Software auf dem neuesten Stand und Sprache auf English.

    Ich erwähne es deshalb weil ich gestern auf eine Einstellung gestoßen bin die sich nur verändern ließ wenn die Sprache

    auf Englisch stand. (Ich weiß aber nicht mehr was das war...)


    Könnte jemand mal den Import bei sich überprüfen?

    Danke schonmal


    Ausserdem habe ich momentan noch ein Problem mit der Positionierung nach einer Werkzeuglängenmessung

    ( Das Offset stimmt scheinbar nicht obwohl es in der Tooltable gespeichert wird) aber da werde ich selber noch

    rumprobieren bevor ich mich wieder an euch wende :)

    Wahrscheinlich wird sich demnächst ein eigenes Unterverzeichniss für Planet Software rentieren :)

  • In welcher Software exportierst du denn?


    Aus Planet heraus?



    Was die Längemessung angeht: ob das Offset nach der Messung geladen wird hängt von deinen settings in Planet CNC ab. Gut möglich das die bei dir so Sitzen das er das nur in die Tool table schreibt. Dann muss das noch mit dem g43 manuell geladen werden. Oder halt die settings passend setzte. Mach da im zweifel mal nen Screenshot wie das bei dir aussieht.

    Grüße,
    Klaus


    Fusion CAD -> Fusion CAM -> Planet CNC TNGV2 -> KMS DIY CNC -> fertig

  • Ich habe Planet-CNC daheim am Laptop und an der Maschine am Desktop, gleiche Versionen.

    Habe dann am Laptop gestern ein paar Fräser angelegt die ich heute an der Maschine erfolglos

    importieren wollte.


    Zur Längenmessung:

    Es war heute zweimal nach einem Fräserwechsel mit anschließender Längenmessung der Fall das der der neue

    Fräser ca. 12mm oberhalb des Werkstückes in der Luft zu fräsen begann.

    Im Gcode unten sieht man das der g43 schon drinstehen würde.

    Hier meine Einstellungen


  • ach so, du willst von einer planet installation zur nächsten, da kannst du einfach die ToolTable.txt vom einen Profil Verzeichnis zum anderen kopieren.



    OK die settings sehen eigentlich gut aus, war denn der erste Fräser sauber eingemessen bevor du z 0 gesetzt hattest?

    Grüße,
    Klaus


    Fusion CAD -> Fusion CAM -> Planet CNC TNGV2 -> KMS DIY CNC -> fertig

  • Als Best Practice hat sich bei mir heraus gebildet das ich die Fräser IMMER NUR an der Tool Change Position wechsel und vorher immer per M06 auf auch in der Software auf den passenden Fräser wechsel. Wenn man sich das mal angewöhnt hat kann da kaum noch was schief gehen.

    Grüße,
    Klaus


    Fusion CAD -> Fusion CAM -> Planet CNC TNGV2 -> KMS DIY CNC -> fertig

  • Oh da kann doch noch einiges schiefgehen :)

    Ich habe da eine komische Situation die ich noch nicht verstehe, wüsste jetzt auch gar nicht wie ich die

    entsprechende Frage formulieren soll.

    Z.B. läuft der Fräserwechsel ein paar Mal völlig fehlerfrei und ein ander mal knallt der Fräser nach einem

    automatischen Wechsel ins Werkstück.

    Oder der obere Limit Switch der Z-Achse löst nach dem Wechse mal aus oder auch nicht und der Wechsel läuft durch,

    habe ich auch noch keine Ahnung woran das liegen kann.

    Ich werde mir erst mal die Tutorials von Planet nochmals reinziehen ?(


    Zwei konkrete Fragen habe ich aber doch noch,

    gibt es noch eine andere empfehlenswerte Informationsquelle ausser deinen Videos, die Website von Planet oder das dort verlinkte Forum?


    Zweitens, bei der Messung mit der Probe kann man folgendes auswählen


    was ist mit Move, Set WO und Set CS

    gemeint?


    Danke

  • hmm das mit dem Werkstück kann ein Problem mit dem Autoreturn sein. Das fährt glaube ich im default XYZ an. Ich habe das bei mir so umgeschrieben das es auf Z Safe hight fährt und dann auf XY und NICHT auf den ausgangs Z punkt.

    Das ist im M06 Script zeile 254. die auskommentieren und er fährt nicht zurück auf Z Höhe (fand das immer ziemlich gruselig)


    Andere Info Quellen kenne ich auch nicht, war mit ein Grund wieso ich die Videos angefangen habe ;)

    Wir haben noch ne kleine gruppe in Signal wo primär Planet Nutzer drinnen sind, wenn du da interesse hast schreib mich mal per PN an.


    Zum Probing:

    Move: Fährt nach dem Probing an den gemessenen Punkt

    Set WO: Setzt das Work Offset Null

    Set CS: Setzt das Aktuelle Koordinatensystem auf Null


    Ob du WO oder CS brauchst hängt von deinen Sonstigen Settings zu dem Thema ab (hatte da mal ein Video zu gemacht)


    Beim Probing etwas vorsicht, ich glaube da sind immer noch nicht alle Icons 100% gemacht, die Ausgangsposition für die Probe ist nicht immer richtig dargestellt. Beim Ecke Antasten zb muss die Probe über der Ecke stehe da er erst mal Z antastet, ich glaube im Bild siehts so aus als müsste die daneben stehen.

    Grüße,
    Klaus


    Fusion CAD -> Fusion CAM -> Planet CNC TNGV2 -> KMS DIY CNC -> fertig

  • Ich frage jetzt mal ganz doof, aber ich hab schon ne menge erlebt, daher frage ich das weil ich nichts mehr ausschließe.

    Also die Frage: Referenzierst du die Maschine bevor du anfängst mit ihr zu arbeiten?


    Bdw. Ich habe bei mir alle Scripte geändert in denen XYZ Simultan verfährt. Habe es so geändert das Z immer als erste auf den Maschinen Nullpunkt fährt und dann erst XY.


    Habe auch alle GUI-Tasten entfernt, bei denen Ddie Maschine Automatisch auf den Werkstück Nullpunkt XYZ fährt entfernt. Es reicht mit wenn sie zu XY fährt. Z wird nur per Handrad oder Programm angefahren.


    Ich habe auch keine GUI-Tasten um XYZ oder XY gleichzeitig abzunullen. Zu oft habe ich mich da vertan.

    Grüße

    Daniel


    Idee -> QCAD-Pro -> Estlcam 11 -> TNG v2 -> PFM2.6

    Edited once, last by Bambusbjoern ().

  • Ist schon eine berechtigte Frage, aber ich Home die Fräse gleich nach dem Einschalten.

    Heute lief ein kleiner Job zur Abwechslung mal Problemlos durch, Ich muss das noch weiter testen. Ich wüsste nicht was

    ich heute anders gemacht habe als gestern...

    Das ändern der Scripte ist sicherlich eine gute Idee, mal sehen ob mir das auch gelingt :)

  • Arbeitest du im Coordinaten System? Seit dem ich auf dieses umgestellt habe, habe ich keine Probleme. Vorher war das Verhalten für mich teilweise nicht Nachvollziehbar.

    Grüße

    Daniel


    Idee -> QCAD-Pro -> Estlcam 11 -> TNG v2 -> PFM2.6

  • Ich habe mir gestern noch das Video dazu von Klaus angesehen und heute mal darauf umgestellt. Habe dann eine kleine Holzarbeit

    gefräst, hat auch gut ausgesehen, mit Haltestegen usw. Am Ende hätte der Fräser laut GCode 20mm nach oben fahren sollen und dann auf 0/0.

    Er ist auch hoch allerdings war die Z Höhe wieder daneben und er ist übers Wekstück geschruppt.


    Habe dann wieder umgestellt auf Work Position und das Teil neu eingemessen und erfolgreich gefräst.

    Momentan bin ich noch etwas ratlos weil ich nicht weiß warums mal klappt und dann wieder nicht.

    Ich muss einfach so lange probieren bis ich verstanden habe was da passiert und wo ich den Denkfehler

    habe.

  • Fährt er da denn laut Zielkoordinaten in die Soll Z Höhe, wenn er durch das Werkstück rauscht? Vielleicht sollte sie laut Steuerung höher sein, bzw. glaubt sie das und ist nur wegen der Mechanik tiefer. Vielleicht die Kupplung locker oder doch irgendwo ein Kabelbruch? Denn das kann dann vorkommen, wenn eine andere Achse an einer bestimmten Stelle ist. Ich hoffe ich habe mich verständlich ausgedrückt. :/

  • Vielleicht komme ich heute an die Fräse und kann weiterprobieren.

    Unter Umständen habe ich zum Einmessen des fest verbauten Längensensors nur einen upassenden Fräser verwendet , denn Planet schreibt in einem Tutorial


    We would like to emphasize that it is very important what kind of tool is used when obtaining Z axis position value, because all future tool measurements will be dependent

    on this value. That is why we call this tool also a default tool. Default tool should not be too long or too short. It should be some normal length.

    Signs that your default tool was not suitable are usually Z axis plunging into machine table or Z axis activating limit switch after tool offset measurement.


    Das ist ja das Verhalten das ich schon hatte.

  • Ne, da geht es darum erstmal ein Referenz Werkzeug zu haben. Das Sollte natürlich kein 150mm langer Bohrer sein.

    Ich glaube du machst grundlegend etwas falsch, oder nicht immer die selbe Prozedur.


    Nur mal so ein Prozedur, die funktionirt.


    1. Homing

    2. Werkzeug einspannen

    3. Werkzeuglänge messen.

    4. Mit diesem Werkzeug die Höhe des Werkstücks ermitteln und abnullen.

    5. Anderes Werkzeug einspannen

    6 Werkzeuglänge messen.



    Wenn die Settings richtig gesetzt sind und im Programm z.b.

    T23 M6 kommt, fordert dich Planet auf das Werkzeug T23 zu wechseln. Dann kannst du bestätigen und es wird automatisch eine Werkzeuglängenmessung vorgenommen.


    Oder du hast eine BT oder ähnliche Aufnahme und hast alle Werkzeuge eingemessen und im Tooltable, dann kann man auch einstellen das die Messung übersprungen wird und das Offset aus dem Tooltable gezogen wird(da muss es natürlich irgendwann vorher mal eingemessen worden sein)


    Aber beide Varianten haben bei mit anstandslos funktioniert.

    Grüße

    Daniel


    Idee -> QCAD-Pro -> Estlcam 11 -> TNG v2 -> PFM2.6

    Edited once, last by Bambusbjoern ().

  • ja so stell ich mir das ja auch vor.

    Ich werde heute zur Sicherheit trotzdem den Toolsensor neu einmessen.

    Ich habe natürlich auch darauf geachtet das die Fräser in jedem Programm die gleichen Nummern haben damit die

    eingetragenen Offsets dann stimmen.

    Ich werde berichten...

  • Hä? Ich glaub wir müssen mal telefoniren.


    Der WLS muss nicht eingemessen werden, nur wenn du den auch als Z-Finder nitzt. Du sagtest aber der WLS sei bei dir fest.

    Die Werkzeugnummern müssen nur Eingehalten werden wenn du die Längen (Offsets) aus dem Tooltable nimmst. Dazu benötigt man aber eine ATC Spindel, jast du die?

    Grüße

    Daniel


    Idee -> QCAD-Pro -> Estlcam 11 -> TNG v2 -> PFM2.6

  • Es wird schon seinen Grund haben wenn Planet in der Anleitung schreibt man soll die Zhöhe des fest verbauten Sensors ermitteln und

    eintragen. Wenns nichts bringt, ist auch nicht viel Aufwand gewesen.


    Nein ich habe keine ATC aber sowohl VCarve als auch Fusion laden nach der Längenmessung die Länge nochmal extra aus der Tooltable.

    Als Bsp ein Anfang von Fusion.


    %

    (SPINDELBEFESTIGUNG 24MM)

    (BEARBEITEN)

    ( HERSTELLER EIGENBAU)

    ( DESCRIPTION GENERIC 3-AXIS)

    (T40 D=6. CR=0. - ZMIN=-25. - SCHAFTFRSER)

    G90 G94 G17 G91.1

    G21

    (WHEN USING FUSION 360 FOR PERSONAL USE, THE FEEDRATE OF)

    (RAPID MOVES IS REDUCED TO MATCH THE FEEDRATE OF CUTTING)

    (MOVES, WHICH CAN INCREASE MACHINING TIME. UNRESTRICTED RAPID)

    (MOVES ARE AVAILABLE WITH A FUSION 360 SUBSCRIPTION.)

    G53 G0 Z0.

    (2D-KONTUR1)

    N10 T40 M6 Hier ist der Toolwechsel mit Messung

    S20000 M3

    G54

    G0 X60.447 Y40.045

    G43 Z15. H40 Und hier wird der Offset nochmal aus der Tooltable geladen

    G1 Z5. F2000.

    Z3.1 F333.33