Hilfe...Erst alles ok, fährt Spindel bei Referenzfahrt runter.

    This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

    • Hilfe...Erst alles ok, fährt Spindel bei Referenzfahrt runter.

      Hallo Zusammen,
      ich hoffe es ist ok, dass ich einen neuen Thread eröffne, im alten wurde mir bezüglich Geschwindigkeitsparameter wirklich gut geholfen - danke dafür!

      Ich versuche wirklich alles doppelt und dreifach zu kontrollieren. Aber verzweifel langsam...

      - Estlcam und WinPC -

      Ich starte WinPC mache eine Referenzfahrt, kontrolliere alle Parameter und die Nullpunkte.
      Lade die Datei, gucke nochmal in die Parametet, damit ich sicher bin, es hat sich nix geändert - zb. die Z Koordinate invertieren.

      Alles ok. Läuft. Ich stoppe, weil ich merke Maße passen nicht und messe meinen Fräser nach... ändere den Durchmesser in der Datei, lade sie normal rein... fahre los... ok.
      Merke - passt noch nicht ganz und wiederhole das.

      Da es schon öfter vorkam... hatte ich so ein Gefühl... habe Referenzfahrt gemacht - aufeinmal, obwohl sich keinerlei Daten geändert haben fährt die Fräse ohne abbremsen langsam nach unten. Ich muss sie dann stoppen.
      Beim Hochfahren läufts dann auch nicht so gut... rattert bleibt stehen, langsam hochfahren geht, schneller dann auch wieder....

      Ich beende WinPc, ziehe stecker, stecke alles wieder an... Starte wieder... ist es leider immernoch so.

      Irgendwann... ganz ohne Muster, gehts dann wieder.

      Ich traue mich echt langsam nicht mehr dran...
      Ich habe auf meinem Laptop die Treiber kontrolliert usw... alles auf aktuellen Stand.

      Weiß einer Rat? Ich ändere nichts, kontrolliere alles immer nochmal... ich versteh das einfach nicht... hatte sogar die Software schon neuinstalliert..hat auch nicht geholfen :(

      Falls jemand kundiges aus NRW Wesel/Recklinghausen kommt... gerne melden...
    • Hallo Steffi,

      aus der Ferne ist es wie immer schwierig....

      Was ist für eine Steuerung verbaut?
      Vielleicht ist ein Schrittmotor Treiber/Endstufe Defekt und bekommt nicht alles sauber mit... ?

      Man könnte dies überprüfen in dem man alles Stromlos macht und mal die Leitungen zwischen zwei Endstufen vertauscht.
      (Ich kenne auch deine verbauten Spindeln/ Motoren nicht kann dir somit auch nicht sagen ob du es einfach 1:1 tauschen kannst / Motorstrom und Schrittauflösung )
      Sollte der Fehler auf Z weg sein und auf einer anderen Achse sichtbar sein, ist es klar eine Endstufe.

      Da ich aber weder deine Steuerung noch die Fräse kenne kann ich da nur raten!
    • KampfHund wrote:

      Hallo Steffi,

      aus der Ferne ist es wie immer schwierig....

      Was ist für eine Steuerung verbaut?
      Vielleicht ist ein Schrittmotor Treiber/Endstufe Defekt und bekommt nicht alles sauber mit... ?

      Man könnte dies überprüfen in dem man alles Stromlos macht und mal die Leitungen zwischen zwei Endstufen vertauscht.
      (Ich kenne auch deine verbauten Spindeln/ Motoren nicht kann dir somit auch nicht sagen ob du es einfach 1:1 tauschen kannst / Motorstrom und Schrittauflösung )
      Sollte der Fehler auf Z weg sein und auf einer anderen Achse sichtbar sein, ist es klar eine Endstufe.

      Da ich aber weder deine Steuerung noch die Fräse kenne kann ich da nur raten!
      Ich habe eine 3S Steuerung und eine Mafell FM 1000

      oh man... das ist echt frustrierend... es gibt aber auch so quasi keine Dienstleister, die sich dem mal annehmen würden - zumindest finde ich da bei google nichts..
    • Also wenn du noch Garantie hast würde ich da mal mit Matthias sprechen was er meint.

      Ansonsten siehe unten ;)

      Die Steuerung hat Stecker für die Achsen, da kann man ohne die Steuerung zu öffnen einfach die Achsen tauschen.
      Du musst nur in deiner Frässoftware die Pins zusätzlich vertauschen

      Also Beispielsweise:
      Z hat Pin 5 und die zweite Achse nehmen wir Y Pin 6 an...
      Stecker um schrauben Z und Y
      In der Software wird Z zu Pin6 und Y zu Pin5
      Das selbe gilt für die Referenzschalter!!! Y und Z die sind nämlich auch in diesem Stecker, sonst knallt es bei einer Referenzfahrt
      Kurz testen mit manueller fahrt ob es passt! ( Am besten die Fräse mit den Achsen in die Mitte fahren.)
      (Die Pins musst du natürlich aus deiner Software ablesen!)

      Programm mit Gcode laufen lassen.


      Sollte der Fehler dann auf der Y Achse sein ist es die Endstufe.
    • Hallo,

      "- Estlcam und WinPC -"
      Da finde ich jetzt keinen Zusammenhang mit Estlcam. Das wird von Dir offensichtlich nicht zum Fahren benutzt.

      Einen Fehler einer Endstufe sehe ich nach der Beschreibung auch nicht. Offensichtlich arbeitet diese die ankommenden Impulse sauber ab.


      " ... Da es schon öfter vorkam... hatte ich so ein Gefühl... habe Referenzfahrt gemacht - aufeinmal, obwohl sich keinerlei Daten geändert haben fährt die Fräse ohne abbremsen langsam nach unten. Ich muss sie dann stoppen."

      Ich habe keinerlei Kenntnisse zu Deiner Steuerung, aber bei den großen Industriesteuerungen ist es so, dass die Achse - nachdem sie den Referenzschalter gesehen hat - wieder langsam von diesem wegfährt. Und wenn der nicht schaltet, fährt sie bis zur Endlage und rattert ... . Also in diesem Fall zuerst den Referenzschalter prüfen.


      "Beim Hochfahren läufts dann auch nicht so gut... rattert bleibt stehen, langsam hochfahren geht, schneller dann auch wieder...."

      Das ist Teil 1 der Geschichte von oben. Die Achse fährt los und sucht den Endschalter, und sucht und ... kommt dann an die Endlage und es rattert.



      Du solltest also den Referenzschalter prüfen und mehrere (20+) Referenzfahrten genau beobachten und analysieren.


      Gruß Raimund (der sich seit ca. 1980 mit NC-Technik befasst hat.)
    • Hallo Raimund,


      rais55 wrote:

      - Estlcam und WinPC -"
      Da finde ich jetzt keinen Zusammenhang mit Estlcam. Das wird von Dir offensichtlich nicht zum Fahren benutzt.
      Sehe ich auch so.

      Wahrscheinlich verwendet Steffi Estlcam nur um den NC-Code zu erzeugen (Abspeichern in Datei), dann NC-Code Datei in WinNC-USB importieren und Fräsvorgang starten.
      (Laut ihrem anderen Posting: Zeichnen und export nach DXF in BeckerCAD, import der DXF Datei in Estlcam, Kontur auswählen/ Werkzeug/ Fräsparameter einstellen)

      Die Kontrolle der Steuerung von MechaPlus und damit der CNC-Fräse Pro Basic H 10/10 übernimmt komplett WinNC-USB.

      @Steffi: Korrekt so ?

      Schon ziemlich komplex. Besonders für den Anfang (Anfänger).

      Hat denn die gesamte Kette von verschiedenen Tools und Dateien schon jemals funktioniert ?
      Und ist sichergestellt dass du die jeweiligen Tools auch so verwendest wie es gedacht ist ?
      Eventuell gibt es ja nicht zusammenpassende Konfigurationen in den jeweiligen Tools.

      Ich kenne leider WinNC-USB nicht, aber benutze schon länger Estlcam an meiner CNC-Fräse.
      Allerdings übernimmt Estlcam bei mir auch direkt die komplette Kontrolle der Steuerung und damit der CNC-Fräse. Was es mir am Anfang deutlich leichter gemacht hatte in das Thema einzusteigen.

      Wenn du möchtest können wir gerne mal telefonieren und skypen.
      Eventuell kann ich helfen. Geht am Telefon oft leichter.
      ctHacks/ CNC14 Klon, Kress 1050, LetMathe MDLCNC + Etlcam Interface, Estlcam: schmiro sperrholzfräse
    • schmiro wrote:

      Hallo Raimund,


      rais55 wrote:

      - Estlcam und WinPC -"
      Da finde ich jetzt keinen Zusammenhang mit Estlcam. Das wird von Dir offensichtlich nicht zum Fahren benutzt.
      Sehe ich auch so.
      Wahrscheinlich verwendet Steffi Estlcam nur um den NC-Code zu erzeugen (Abspeichern in Datei), dann NC-Code Datei in WinNC-USB importieren und Fräsvorgang starten.
      (Laut ihrem anderen Posting: Zeichnen und export nach DXF in BeckerCAD, import der DXF Datei in Estlcam, Kontur auswählen/ Werkzeug/ Fräsparameter einstellen)

      Die Kontrolle der Steuerung von MechaPlus und damit der CNC-Fräse Pro Basic H 10/10 übernimmt komplett WinNC-USB.

      @Steffi: Korrekt so ?

      Schon ziemlich komplex. Besonders für den Anfang (Anfänger).

      Hat denn die gesamte Kette von verschiedenen Tools und Dateien schon jemals funktioniert ?
      Und ist sichergestellt dass du die jeweiligen Tools auch so verwendest wie es gedacht ist ?
      Eventuell gibt es ja nicht zusammenpassende Konfigurationen in den jeweiligen Tools.

      Ich kenne leider WinNC-USB nicht, aber benutze schon länger Estlcam an meiner CNC-Fräse.
      Allerdings übernimmt Estlcam bei mir auch direkt die komplette Kontrolle der Steuerung und damit der CNC-Fräse. Was es mir am Anfang deutlich leichter gemacht hatte in das Thema einzusteigen.

      Wenn du möchtest können wir gerne mal telefonieren und skypen.
      Eventuell kann ich helfen. Geht am Telefon oft leichter.
      Vielen Dank für eure Antworten.

      Genau so mache ich es. Ich habe es einfach nur als Info dabei geschrieben, falls es relevant ist.
      Ich habe mit Matthias von MechPlus telefoniert und er ist sich sicher, dass ich wohl ein Software Problem habe. Wenn ich den Ref Schalter an der Z Achse manuel drücke, erkennt er das in der Software.
      Ich hatte die Software zwar letzte Woche auch schonmal neu installiert, alle Treiber kontrolliert, keine Stromspareinstellungen usw... aber ich werde dann mal einen anderen Laptop auprobieren irgendwas muss da ja nicht stimmen.

      Anfürsich hat das Fräsen durchaus schonmal geklappt, bis auf die Geschwindigkeitseinstellungen , die WinPc von Estlcam nicht übernommen hat - und das er immer 2mm zuviel wegfräst... also statt 7mm Schlitze hab ich 9mm. aaaber, als ich da weiterkam kam dann dieses Problem.
      Normal kann ich mich immer gut in Sachen reinfuchsen, umso mehr ärgert es mich, dass es bestimmt einfach irgendein sehr sehr blöder Anfängerfehler ist.
    • Hallo BLSteffi,


      BLSteffi wrote:

      Normal kann ich mich immer gut in Sachen reinfuchsen, umso mehr ärgert es mich, dass es bestimmt einfach irgendein sehr sehr blöder Anfängerfehler ist.
      Muss nicht unbedingt ein Anfängerfehler sein.
      Die gesamte Kette von CAD bis zur CNC-Fräse ist schon sehr komplex. Da können viele Fallstricke sein. Da kann auch einem Erfahreneren Fehler passieren.

      Nicht verzagen !
      Und mein Angebot für Hilfe am Telefon/ Skype gilt weiterhin.

      Gruss
      Ralf
      ctHacks/ CNC14 Klon, Kress 1050, LetMathe MDLCNC + Etlcam Interface, Estlcam: schmiro sperrholzfräse
    • Ich verwende seit fast 10 Jahren WinPCNC Economy. Der Grund weshalb ich nie auf die USB Version gewechselt habe sind genau solche Beschreibungen wie Du sie abgibst. USB ist keine sehr stabile Verbindung und für Maschinensteuerung meiner Meinung nach völlig ungeeignet. Erstmal ist schon die Verkabelung störanfällig und man muß ein sehr gut geschirmtes Kabel verwenden. Sonst können Störungen so reinschlagen das die Steuerung spinnt. Wenn während der Laufzeit irgend etwas mit einem anderen USB-Port geschieht stockt die Verbindung schon mal und die Maschine verliert die Echtzeitverbindung.
      Gib "WinPCNC USB Probleme" in die Suchmaschine Deiner Wahl ein und Du wirst erschlagen mit solchen Beiträgen.
      Wenn Du bei WinPC-NC bleiben möchtest würde ich mir das beste USB Kabel kaufen um Störungen ausschliessen zu können.
      Dann gibt es in Win-PCNC die Möglichkeit ein Protokoll anzuschalten wo man eventuell nachvollziehen kann woher der Fehler kommt. (Herrn Lewetz fragen)
      Ansonsten ist es besser einen möglichst alten langsamen Rechner zu benutzen. Neue schnelle Rechner haben oft eine zu hohe Taktfrequenz für Echtzeitsteuerung.


      grüße
      ralfg
    • Hallo Ralf!
      Danke!!! Ich bin mir inzwischen sehr sicher, dass es due USB Verbindung sein muss.
      Mein bester Freund hat mir heute geholfen.
      Wir haben alle PC Einstellungen überprüft, anderen Laptop benutzt .

      Erst lief alles gut, habe sogar etwas gefräst, aber mitten im Job trat das Problem wieder auf.

      Habe jetzt versucht mal im Estlcam die CNC Steuerung versucht einzustellen. Estlcam zeigt due Com3 an, so hat mein bester Freund es auch im Pc gesehen, WinPc zeigt aber wohl com1 an und es kam folgender Fehler beim Speichern:




      Also bleibt mir nur ein besseres USB Kabel oder alles ändern?
      Images
      • 20200706_165813.jpg

        235.82 kB, 1,024×576, viewed 18 times
    • Ja, steht doch da, besser geschirmtes Kabel, das kostet nicht viel.
      Den zweiten Punkt kenne ich auch, bei mir hat die Werkstatt keine Erde, sondern noch ein antikes TN-C-System. Ich habe damit Probleme wegen unterschiedlicher Potentiale. Erst nachdem ich einen alten, nicht mehr angeschlossenen Blitzableiter als separaten PE eingebunden habe konnte ich die Probleme der PEN Schaltung eliminieren.

      Ein gutes USB Kabel in Industriequalität hat außer einer mindestens 2-fachen Schirmung noch Ferritkerne an jedem Ende, dickere Kupferleitungen und vergoldete Stecker.
      Nur mal ein Beispiel. Die Ferritkerne gibt es auch einzeln. Ansonsten würde ich das Kabel immer so kurz wie möglich machen.

      grüße
    • fraesoholic wrote:

      Ja, steht doch da, besser geschirmtes Kabel, das kostet nicht viel.
      Den zweiten Punkt kenne ich auch, bei mir hat die Werkstatt keine Erde, sondern noch ein antikes TN-C-System. Ich habe damit Probleme wegen unterschiedlicher Potentiale. Erst nachdem ich einen alten, nicht mehr angeschlossenen Blitzableiter als separaten PE eingebunden habe konnte ich die Probleme der PEN Schaltung eliminieren.

      Ein gutes USB Kabel in Industriequalität hat außer einer mindestens 2-fachen Schirmung noch Ferritkerne an jedem Ende, dickere Kupferleitungen und vergoldete Stecker.
      Nur mal ein Beispiel. Die Ferritkerne gibt es auch einzeln. Ansonsten würde ich das Kabel immer so kurz wie möglich machen.

      grüße
      Danke, besorge ich mir direkt :)
    • Hallo BLSteffi,



      BLSteffi wrote:

      Danke, besorge ich mir direkt
      Sehr gut.


      BLSteffi wrote:

      Habe jetzt versucht mal im Estlcam die CNC Steuerung versucht einzustellen.
      Was meinst du damit konkret ?
      Willst du jetzt Estlcam nutzen um die Mechaplus-Steuerung direkt zu steuern (und nicht über WinNC-USB) ? Oder versehe ich das falsch ?

      Unabhängig davon kannst du mal bitte sagen welche Mechaplus-Steuerung du konkret hast ? Bitte mit Link auf die Mechaplus-Website.

      Und wie ist denn der PC/ Notebook mit der Mechaplus-Steuerung im Normal-Fall (BeckerCAD --> Estlcam --> WinNC-USB --> Mechaplus Steuerung) angeschlossen ? Gern mit Foto.

      Ist bei dir auch die kleine ncUSB Box (lewetz.de/de/sample-sites-2/winpc-nc/winusb) zwischen deinem PC/ Notebook und der Mechaplus-Steuerung ?


      Das Schaubild im Detail wäre dann wie folgt:

      Hardware 1: PC/Notebook (BeckerCAD --> Estlcam --> WinNC-USB Software ) --> Hardware 2: ncUSB Box --> Hardware 3: Mechaplus Steuerung --> Hardware 4: CNC-Fräse

      Diese Infos würden ggf. helfen dein Problem besser zu verstehen/ zu lösen.

      Gruss
      Ralf
      ctHacks/ CNC14 Klon, Kress 1050, LetMathe MDLCNC + Etlcam Interface, Estlcam: schmiro sperrholzfräse

      The post was edited 3 times, last by schmiro ().

    • schmiro wrote:

      Das Schaubild im Detail wäre dann wie folgt:

      Hardware 1: PC/Notebook (BeckerCAD --> Estlcam --> WinNC-USB Software ) --> Hardware 2: ncUSB Box --> Hardware 3: Mechaplus Steuerung --> Hardware 4: CNC-Fräse

      Diese Infos würden ggf. helfen dein Problem besser zu verstehen/ zu lösen.

      Gruss
      Ralf
      Genauso ist es hier!

      Man kann ja auch über Estlcam eine CNC Steuern, ich habe es einfach nur für die Fehlersuche ausprobiert - und es hatte mir direkt schon beim Versuch sich zu verbinden den USB Fehler angezeigt.

      Ich habe diese hier:
      Pro Basic H 10/10 montiert inkl. Steuerung
      dazu dann die ncUSB Box
      dies müsste dann die Steuerung sein
      3S Steuerung

      *3 Schrittmotoren sind mit Steuerung fertig verkabelt - 2-3A 2Phasen 1,8°-
      * Endschalter sind angeschlossen
      * inkl. Frässpindelhalterung 43mm
      *3 S Steuerung 1,4A- 4,2A - 3A RMS-Phase, 3 Achsen, 2 Steckdosen 230V 1000W über Relais schaltbar
      * Anschluss für 3 Endschalter XYZ, Notaus und Längensensor
      * 1/2 - 1/125 Mikroschrittbetrieb über Jumper einstellbar
      * Industrienetzteil intern 28V 6,5A Meanwell

      *Mafell FM 1000
    • Hallo BLSteffi,

      BLSteffi wrote:

      Genauso ist es hier!
      OK, verstanden.
      Dann hast du ja noch eine weitere Komponente in deiner Kette.


      Noch ein paar Fragen zu USB, falls der Austausch des USB Kabels nicht hilft:

      Wie wird denn die kleine ncUSB Box mit Strom versorgt ?
      Direkt aus dem USB Kabel oder hat die eine eigene Stromversorgung ?

      Und hast du eventuell das USB Kabel zur ncUSB Box an einem USB Hub, statt direkt am PC/ Notebook angeschlossen ?

      BLSteffi wrote:

      Man kann ja auch über Estlcam eine CNC Steuern,
      Noch ein kleiner Hinweis dazu (Falls du mal mit Estlcam direkt deine CNC Fräse steuern wolltest).

      Mit Estlcam direkt eine CNC-Fräse steuern klappt sehr gut.
      Mache ich so mit meiner Sperrholzfräse ohne Probleme (und viele andere auch). Hat den Vorteil, dass man weniger Komponenten hat. Man benutzt das gleiche Progromm für den NC Code erzeugen und ablaufen zu lassen/ die Maschinen-Steuerung zu steuern.

      Aber damit das klappt benötigt Estlcam bei den meisten Maschinen-Steuerungen einen kleinen Adapter (Auf Arduino Basis, fertig aufgebaut oder selbstgebaut), der an den LPT-Anschluss der Steuerung angeschlossen wird.
      Ausser die Steuerung ist GRBL kompatibel oder vom Steuerungshersteller speziell für Estlcam entwickelt.




      Siehe dazu auch estlcam.de/steuerung_hardware.php

      So weit ich weiss ist die Mechaplus-Steuerung nicht GBRL kompatibel und auch nicht speziell für Estlcam entwickelt.
      Damit kann Estlcam nicht direkt deine Mechaplus-Steuerung über die ncBox USB ansteuern.

      Aber mit z.b. dem Estlcam LPT Adapter estlcam.de/lpt_adapter.php (ca. 30 Eur) geht das easy. WinNC USB und ncBox USB fliegen dann raus.

      Noch weiter viel Erfolg mit deiner CNC und ich drücke dir die Daumen dass es das USB Kabel war !


      Gruss
      Ralf
      ctHacks/ CNC14 Klon, Kress 1050, LetMathe MDLCNC + Etlcam Interface, Estlcam: schmiro sperrholzfräse
    • Hallo zusammen

      Ich habe bei Reichelt ein durchsichtiges, mit Ferritkernen ausgestattet USB Kabel in Verwendung, 2 m Länge und gehe damit auf die Estlcam Platine.
      Ich fräse jetzt seit mehreren Monaten damit und hatte noch nie USB Probleme.

      Bei mir tritt ein USB Problem nur auf, wenn das USB Kabel nicht angeschlossen ist und ich Estlcam starte, dann vermisst er natürlich seinen Port. :D Ist dann auch schnell erledigt, USB dran und Estlcam neu starten.

      Muss aber noch sagen, dass ich keinen FU oder andere grössere Störquellen bei mir habe, nur einen Kress Fräsmotor.

      Grüsse

      Dieter
      Sie dürfen nicht alles glauben was sie denken. (Heinz Erhardt) ;)
    • Hallo Steffi,

      ich nutze den EstlCam Parallel-Adapter und gehen damit auf eine TripleBeast.
      Das wäre vergleichbar wenn Du den Parallel-Adapter an den Parallel-Port der Mecha Plus anschließt.

      Auch ich hatte mit schlechtem USB-Kabel Abbrüche, insbesondere wenn ich den Frequenzumrichter für die 2,2KW-Spindel in demselben Schaltschrank gestartet habe.

      Nach Austausch des Kabels (Ferritkern, dicker, kein Gold) funktioniert alles super.

      Viel Erfolg
    https://www.daswetter.com/