Baubericht Fenja M800 -lordwimsey- (Peter)

    This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

    • lordwimsey wrote:

      Edit2:
      Die sind ja 12mm im Durchmesser.Und Ihr sagt alle nix...
      Ich hab dir ja nen link geschickt für 8 mm ... die waren dem Herrn ja nicht fein genug ... :D :D #Spass

      Davon mal ab das du 4 mm Fahrweg je Achse verlierst ( wohl nicht so tragisch ) wird das aufbohren schon eher ne Aktion. zumal ein paar der dafür vorgesehenen Bohrungen nah am Rand sitzen, evtl wird das dann sehr knapp mit dem Rest Futter.
      Ich würd mir den Aufwand und die Nachteile sparen. Schick die zurück und hol dir die 8 mm. Auf die 2 Tage kommts auch nicht mehr an , oder ?

      Edit: ich hab meine Sensoren mit Madenschrauben fixiert M4. Das geht super und die stehen nicht nach außen raus. Halt nur Löcher dafür bohren und Gewinde rein. In meinem Baubericht hab ich das irgendwo erwähnt
      Gruss Andy

      Biber 800 - China 1,5 kw Luft/HY - Leadshine DM556 - Estlcam Board

      Cad: Fusion 360 Cam: Estlcam

      The post was edited 1 time, last by Ruhrpott Andy ().

    • Hallo zusammen,

      nur kurze Rückmeldung:
      die neuen induktiven Näherungsschalter NPN NC (aus Andys Quelle... jaja. :rolleyes: ) funktionieren wie erwartet.
      Schnell die Spannungsversorgung der Inis von 5V auf 12V umgebastelt, ausprobiert: geht. Einfach so.


      Bei den Chinesen habe ich einfach mal nach einem Refund gefragt, aber der Kauf sei zu lange her.
      Und "wenn da NPN draufsteht, ist das auch NPN"...

      Ich hätte noch die Möglichkeit, einen Disput zu eröffnen, aber den Trubel ist es mir nicht wert.


      Jetzt geht es weiter mit Strippen ziehen.



      Für die Wasserkühlung hatte ich schon letztes Jahr eine große Eheim-Pumpe (1246) besorgt. Die hab ich ausprobiert und bin ziemlich beeindruckt, die macht ganz schön Druck. :D

      Als Schlauch habe ich vom Freund Polyamid-Rohr bekommen. Das ist allerdings sehr steif, tatsächlich fast mehr wie ein Rohr, nicht wie Schlauch.
      Ich habe das gestern mal probehalber durch die Schleppkette gezwängt, aber das ist echt krass gebogen. Ich mein- die Kette bekommt einen schönen Bogen davon, aber ob das Rohr das auf Dauer mitmacht... :/
      Ich werde mir also lieber noch Schlauch besorgen.


      Grüße,
      Peter
      Compared to a properly tailored dinner jacket with a self-tied bow tie and elegant turndown-collar formal shirt, the black suit is utterly pedestrian.
    • Freut mich mit den Sensoren... top.

      Ja den Schlauch würd ich schon flexibel nehmen, aber schon so steif das er nirgendwo knicken kann
      Hier gibts bestimmt genug Experten die passsende Schläuche empfehlen können. Druckluft Schlauch in blau sohl wohl sehr gut sein
      Gruss Andy

      Biber 800 - China 1,5 kw Luft/HY - Leadshine DM556 - Estlcam Board

      Cad: Fusion 360 Cam: Estlcam
    • Hi Andy,

      ich habe PU-Schlauch im Auge, das wird an vielen Stellen empfohlen, aber ich finde widersprüchliche Angaben über den Innendurchmesser...
      (z.B. hier: Thread in anderem Forum)

      Mein PA-"Rohr" ist 8x1.25, also Innen Ø5,5mm

      Ich habe jetzt diese gefunden:

      Ebay, 8x6

      Ebay, 8x5

      Ich mag nicht gern die Anschlüsse abbrechen bei dem Versuch, den zu dünnen Schlauch draufzupopeln, aber dicht soll's trotzdem werden. 8|


      bzgl. der Farbe:
      Auch wenn ich irgendwo gelesen habe, dass klarer Schlauch das Algenwachstum begünstigt, find ich ganz gut, wenn man ein wenig reingucken kann. Soviel Licht gibt's im Keller nun auch nicht. :rolleyes:

      Ich tendiere im Moment zu 8x6.


      Grüße,
      Peter
      Compared to a properly tailored dinner jacket with a self-tied bow tie and elegant turndown-collar formal shirt, the black suit is utterly pedestrian.
    • Ja, ich glaube 8x6 ist der richtige. Und wegen der Dichtigkeit ... das sind doch Quetschverschraubungen an der Spindel oder ?
      Und zum Thema reinschauen ... Wasser im Klarsichtschlauch sieht man nicht so dolle oder ? :) Es gibt so geile Duchfluss Anzeiger--- da sieht man das super ob's fließt

      Guckst du hier : ebay.de/i/401715930791?chn=ps
      Gruss Andy

      Biber 800 - China 1,5 kw Luft/HY - Leadshine DM556 - Estlcam Board

      Cad: Fusion 360 Cam: Estlcam

      The post was edited 1 time, last by Ruhrpott Andy ().

    • Ruhrpott Andy wrote:

      Es gibt so geile Duchfluss Anzeiger
      Den da hab ich zuhause:



      ;)



      GuiHue wrote:

      8x6 und Quetschverbinder passte bei mir.

      Durchflussanzeigen: Kann man machen, achtung, auf Schraubverbinder oder Pneumatiksteckverbinder achten. Auf reines Aufstecken würde ich verzichten... ;) Das gibt Pfützen,.
      VG
      Guido
      Tja, dann werd ich mal gucken, wie ich das dichtkriege... :/


      Grüße,
      Peter
      Compared to a properly tailored dinner jacket with a self-tied bow tie and elegant turndown-collar formal shirt, the black suit is utterly pedestrian.
    • lordwimsey wrote:

      Ich verstehe, was Ihr meint, und ein bisschen denke ich genauso. Aber dass ich das noch nichtmal hinbekommen habe, Ein Freecad 0.18* zu installieren, hatte mich etwas zum Upgrade geschubst. (Also, darüber nachzudenken. Noch ist Wheezy drauf, Stretch mit Preempt hatte ich nur vom Stick gebootet)
      Der Rechner hängt auch im Netz inkl. Internet, da ist es normalerweise auch keine coole Idee, auf einem Betriebssystem zu bleiben, dass nicht länger maintained wird.
      Jetzt habe ich erst geschnallt was du meinst. Ich wollte am WE was nach installieren, aber geht nicht, weil die Server nicht mehr erreicht werden können ;(
      LG Albert
      Nur Fliegen ist schöner.
    • Das ist erst seit Ende April der Fall.

      in der /etc/apt/sources.list habe ich jetzt das security-Repo auskommentiert. Es kommen ja eh keine Updates mehr...

      Wenn ich zu Hause bin gucke ich in meine aktuelle sources.list rein. Ich bin mir nicht mehr sicher, ob ich das andere Repository getauscht hatte oder nicht. Jedenfalls konnte ich wieder Kleinkram installieren (HTop in dem Fall) und es kommen keine Errors mehr bei update.

      Werde mich nochmal damit herumschlagen müssen, um den Kamera-Preview wieder ans Laufen zu kriegen nach meinem kleinen Ausflug zu STretch und Preempt-RT... :whistling:

      Grüße,
      Peter
      Compared to a properly tailored dinner jacket with a self-tied bow tie and elegant turndown-collar formal shirt, the black suit is utterly pedestrian.
    • millingpenguin wrote:

      Genau, die Kamera wollte ich auch auf meiner Simulations Maschine zum Laufen kriegen. Auf der richtigen läuft sie schon. Kannst du die sources.list dann sharen?
      Ja klar! Allerdings ist da glaubich nur noch ein Eintrag drin. Die Kamera hab ich noch nicht wieder am Laufen, hoffe aber das klappt jetzt.

      Grüße,
      Peter
      Compared to a properly tailored dinner jacket with a self-tied bow tie and elegant turndown-collar formal shirt, the black suit is utterly pedestrian.
    • Hallo zusammen,

      hier wie versprochen, die sources.list:


      Source Code: /etc/apt/sources.list

      1. :~$ cat /etc/apt/sources.list
      2. deb http://archive.debian.org/debian/ wheezy contrib main non-free
      3. # deb http://archive.debian.org/debian-security/ wheezy/updates contrib main non-free
      4. # deb http://http.debian.net/debian wheezy main contrib non-free
      5. # deb-src http://http.debian.net/debian wheezy main contrib non-free
      6. # deb http://http.debian.net/debian wheezy-updates main contrib non-free
      7. # deb-src http://http.debian.net/debian wheezy-updates main contrib non-free
      8. # deb http://security.debian.org/ wheezy/updates main contrib non-free
      9. # deb-src http://security.debian.org/ wheezy/updates main contrib non-free
      sie besteht tatsächlich nur noch aus dem einen Eintrag oben (Zeile 2).

      Ich probiere jetzt als nächstes, die Kamera wieder zum Laufen zu bringen und werde berichten.

      Grüße,
      Peter
      Compared to a properly tailored dinner jacket with a self-tied bow tie and elegant turndown-collar formal shirt, the black suit is utterly pedestrian.
    • Also, nach dieser Anleitung:

      Anleitung von "XP-Killer"...


      XP-Killer wrote:

      Kamera Einbindung als Tab

      Um eine USB Cam in gmoccapy einzubinden, braucht man natürlich erst einmal eine USB Endoscop cam mit LED beleuchtung. Als erstes habe ich die Schritte:
      sudo apt-get install qv4l2
      Terminal öffnen
      qv4l2 eingeben und schauen, ob die Kamera erkannt wird. (Livebild starten) funktioniert bei mir einwandfrei «
      sudo apt-get install python-opencv
      sudo apt-get install v4l2-utils
      sudo apt-get install v4l2ucp
      angefügte Datei runterladen, und von camview.txt in camview.py ändern
      im Terminal in das Verzeichnis gehen, wo camview.py gespeichert wurde.
      python camview.py eintippen und staunen ;-), funktioniert auch «

      Hier sind die Dateien, die benötigt werden. camview-tar

      camview.glade gehört in das Config Verzeichnis (wo auch die gmoccapy.ini ist)

      camview.py
      hal_python.xml
      hal_pythonplugin.py
      gehören nach /usr/lib/pymodules/python2.7/gladevcp
      und
      /usr/share/pyshared/gladevcp

      vorher aber bitte die vorhandenen unten angeführten Dateien sichern.
      hal_python.xml
      hal_pythonplugin.py

      In der gmoccapy.ini muß nun noch unter der Rubrik [DISPLAY] drei Zeilen eingefügt werden.

      EMBED_TAB_NAME = Kamera
      EMBED_TAB_LOCATION = ntb_preview
      EMBED_TAB_COMMAND = gladevcp -x {XID} camview.glade
      gmoccapy-cam1

      Danach sollte das Kamerabild unter dem User Tab (Kamera) erscheinen.

      Hat es fast sofort funktioniert. Einzig das Paket "v4l2-utils" wurde nicht gefunden.
      Bei mir hat es aber mit "v4l-utils" funktioniert.



      Grüße,
      Peter
      Compared to a properly tailored dinner jacket with a self-tied bow tie and elegant turndown-collar formal shirt, the black suit is utterly pedestrian.
    • Mit der Kamera kann man das Werkstück einrichten, den Nullpunkt für den Fräsjob setzten oder auch Bohrungen und diverse Abstände messen.
      Das Plugin kann in der Regel auch beim Nullpunkt setzen automatisch den Offsetwert der Kamera zum Fräser verrechnen.
      Ich graviere immer auf dem Nullpunkt ein Kreuz mit einem feinen Gravierfräser und fahre dann mit der Kamera auf das Kreuz.
      So kann ich den Offsetwert und die Kameraausrichtung zur X und Y Achse kontrollieren. Ob diese sich gedreht hat und der Offsetwert noch stimmt.
      Bei den Kameras kann sich durch die Vibrationen beim Fräsen leicht mal die Linse verstellen.
      Die Kamera muss natürlich auch entlang der Z-Achse sauber ausgerichtet sein, sonst wandert das Kreuz seitlich weg, wenn man in der Z-Achse verfährt.
      Das kann auch mithilfe der Gravur geprüft werden.
    • Alois73 wrote:

      Mit der Kamera kann man das Werkstück einrichten, den Nullpunkt für den Fräsjob setzten oder auch Bohrungen und diverse Abstände messen.
      Das Plugin kann in der Regel auch beim Nullpunkt setzen automatisch den Offsetwert der Kamera zum Fräser verrechnen.
      Ich graviere immer auf dem Nullpunkt ein Kreuz mit einem feinen Gravierfräser und fahre dann mit der Kamera auf das Kreuz.
      So kann ich den Offsetwert und die Kameraausrichtung zur X und Y Achse kontrollieren. Ob diese sich gedreht hat und der Offsetwert noch stimmt.
      Bei den Kameras kann sich durch die Vibrationen beim Fräsen leicht mal die Linse verstellen.
      Die Kamera muss natürlich auch entlang der Z-Achse sauber ausgerichtet sein, sonst wandert das Kreuz seitlich weg, wenn man in der Z-Achse verfährt.
      Das kann auch mithilfe der Gravur geprüft werden.
      Sehr cool, interessantes Thema, Danke für die Info
      Gruss Andy

      Biber 800 - China 1,5 kw Luft/HY - Leadshine DM556 - Estlcam Board

      Cad: Fusion 360 Cam: Estlcam
    • Im Moment geht es nur schleppend voran.
      Die induktiven Referenzschalter habe ich jetzt schonmal vorläufig installiert. Dabei habe ich gemerkt, dass der Ini für die Tischachse zu weit hervorsteht, so dass die Schleppkette nicht mehr vorbeipasst. Der muss also auf die andere Seite.

      Übrigens- der Schlauch 8x6 (also, außen 8mm, innen 6mm) passt perfekt auf die Chinaspindel.





      Das Kabel zur Spindel ist auch schon durch die Schleppketten gelegt.



      Und damit nicht hinterher alles fertig ist und ich ohne Werkzeug dastehe, habe ich mir erstmal auf Verdacht Fräser bei Sorotec gekauft.
      (An billigen China-Quellen mit akzeptabler Qualität zum Abbrechen für Holz wäre ich interessiert...)
      Die waren aber auch nicht so teuer. 2x 3mm Einschneider und 2x 3mm Zweischneider.



      Und der Frequenzumrichter ist bestellt. Sollte morgen eintreffen laut UPS. Ich habe mich am Ende für den Sourcetronic ST500 entschieden. Die Firma macht mir einen sehr guten Eindruck, die Doku (Manual, FAQ, auch Emailkontakt) gefallen mir sehr, und für die quasi baugleichen Powtrans gibts ja massenhaft Anleitungen und Erfahrungen.
      Ich habe die berühmte Anleitung vom Heini mit der Parameterliste des Handbuchs des ST500 verglichen, und die Parameter sind allesamt dieselben.


      Grüße,
      Peter
      Compared to a properly tailored dinner jacket with a self-tied bow tie and elegant turndown-collar formal shirt, the black suit is utterly pedestrian.
    • So. Ich habe den Frequenzumrichter ausprobiert. Die gute Nachricht: Die Spindel dreht.

      Allerdings, soo einfach laufen die Dinge ja nicht...


      Zuerst mal musste ich den FU am Paketshop abholen. UPS hat es soweit ich mich erinnern kann, noch nie geschafft, bei uns jemanden anzutreffen. (DHL kommt immer an.) :thumbdown:

      Das überraschend kleine Päckchen beinhaltete den ebenso überraschend kleinen FU, mit nichts weiter als einer CD, auf der sich einige PDFs befinden. Handbuch (deutsch und englisch), Datenblatt, und ein Inbetriebnahmeguide.




      Grob (ziemlich genau) der Anleitung Heinis folgend, habe ich den FU parametriert. Die Anleitung ist für einen Powtran 9100, daher habe ich parallel jeden Parameter nach der Ellenlangen Parameterliste aus dem sehr guten Handbuch von Sourcetronic nachverfolgt um sicherzugehen, dass ich die richtigen Parameter einstelle.

      Begonnen habe ich mit der F0 Gruppe. Als erstes habe ich die Frequenzauflösung (F0.02) auf 0.1Hz gesetzt, damit ich mir nicht später die bereits gesetzten Werte verändere.

      Danach bin ich nach und nach alle Parameter der Anleitung durch gegangen. Dabei habe ich parallel die Parameterliste überflogen, um zu sehen, ob noch andere Einstellungen nötig sein könnten.

      Gleich zu Beginn schreibt Heini von "V/f-Vectorcontrol" (F0.00), was für mich in sich widersprüchlich scheint, denn ich hatte im Vorfeld immer unterschieden zwischen V/f-Modus und Vektorregelung. Ich würde den FU letzlich gern als Vectorcontrolled laufen lassen, deswegen bin ich von der Anleitung abgewichen und habe "0" anstatt "2" ausgewählt (Vektorregelung ohne Drehzahlsensor).

      Hierfür ist übrigens laut Manual zwingend die Motorerkennung (s.u.) notwendig, für V/f-Modus nicht.


      Für F0.13 und F0.14 Beschleunigungs- und Bremszeit) gibt es einen Fallstrick, der im Parameter F0.15 liegt, nämlich die Einheit. In F0.15 kann man festlegen, ob die Zeiten in Sekunden (Parameterwert 0), Zehntelsekunden (1) oder Hundertstel (2) angegeben werden sollen. Default ist bei dem ST500 "1", also Zehntelsekunden!


      Die Motorwerte unter B0 habe ich genauso eingegeben, wie bei Heinis Anleitung vorgeschlagen. Einzig der Nennstrom ist bei meiner Spindel nur 8A. (Und die Nennspannung 220V anstatt 230V...)

      So. Der spannende Moment, die automatische Motordatenerkennung.

      B0.27 auf "2" für lastfreie Messung des Asynchronmotors und "Run".

      Die Spindel fiept ein wenig, dann läuft sie in einer Rampe auf Drehzahl, verweilt ein wenig in der Drehzahl und verlangsamt sich anschließend bis zum Stop. Der FU springt von der "Tune Doing" Anzeige zurück auf den Homescreen mit der Zielfrequenz.

      Erfolg? Augenscheinlich ja, ABER: wenn ich nun bei einer Frequenz von 100Hz (andere auch ausprobiert) auf "run" drücke, brummt die Spindel, zuckt ein wenig und dann geht der FU in den Fehler:

      Source Code

      1. Err. 40
      2. CbC


      Laut Manual heißt das

      Handbuch wrote:

      Stromgrenze überschritten


      Mögliche Ursachen: Last am Motor zu groß oder Motor blockiert oder Umrichterleistung zu klein

      Das scheint mir allerdings nicht die Ursache zu sein, denn
      1. Beim Einmessen dreht die Spindel anscheinend problemlos
      2. Nach Umstellen auf V/f-Modus (F0.00 =2) kann ich die Spindel problemlos starten und die Frequenz munter zwischen 100Hz (hab ich als Minimum eingetragen) und 400Hz, also zwischen 6000 und 24000rpm laufen lassen.


      Ich werde weiter forschen müssen. Mir ist später (nicht mehr in der Werkstatt) aufgefallen, dass der Default für den von Heini beschriebenen Drehmoment-Boost zwar bei 0% (bedeutet Automatik) ist, aber die Grenzfrequenz schon bei 15Hz, also sehr früh, weit unterhalb meines eingestellten Minimums, abschaltet. Hier hatte ich noch nichts geändert.

      Da bin ich im Moment ratlos, aber unter V/f läuft es ja schonmal.


      Über Tipps freue ich mich natürlich sehr.

      Grüße,
      Peter
      Compared to a properly tailored dinner jacket with a self-tied bow tie and elegant turndown-collar formal shirt, the black suit is utterly pedestrian.